Back to overview
Degraded
SMS unavailable
Apr 09 at 06:38am CST
Affected services
Pharmetika
Resolved
Apr 09 at 07:14am CST
Our upstream SMS carrier has resolved the issue.
Affected services
Created
Apr 09 at 06:38am CST
Our carrier is currently investigating a system wide issue. No ETA has been provided at this time.
Affected services