Back to overview
Degraded

Faxes - incoming faxes failing

Oct 28, 2024 at 01:06pm UTC
Affected services
Pharmetika

Resolved
Oct 28, 2024 at 07:53pm UTC

Fax services have been restored. We are asking our carrier for a root cause and will be evaluating mitigation steps.

Created
Oct 28, 2024 at 01:06pm UTC

Our upstream fax carrier is not delivering faxes to us currently. We have escalated a ticket, but do not yet have an ETA on resolution. The issue started about 6:30am EST.